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Microsoft Excel

Excel is a very powerful and flexible application, and very often it's underused. You can do anything from adding up a few figures using simple formulae, to creating complete systems that resemble relational databases (see examples below). While most of the formulae available are numerical or statistical, there are also text and data lookup functions. Here are a few features that you may not know about or may not have used before.

Validation

Using the validation functions in Excel (on the Data menu), it is possible to check ranges of numbers or the lengths of strings entered, and also to customise the messages that appear when the validation fails. You can even add prompts so that the user is told what to enter when he or she clicks on the cell. This is quite straightforward - just select the type of validation you require, and enter the limits and messages.

Probably the most useful type of validation is List. The checks entries against a list of valid entries, either typed into the Validation dialogue or from a range on the spreadsheet. More usefully, however, it creates a combo box on the spreadsheet that allows the user to select from the valid entries using the mouse. This is particularly effective when combined with the vlookup() function (see below). The only thing to note is that if you want to use a list from the spreadsheet, the list needs to be on the same sheet.

Protecting Cells

If you've created an elaborate system that takes user-entered variables and produces some sort of outcome in other cells, then the last thing you want is your user deleting the formulae. Because your formulae generally won't need to be changed, and what you can do is protect the cells that contain them. In fact, if you protect all of the cells into which the user does not need to enter any values, it has the additional benefit of assisting navigation, as the TAB key moves the cursor between unprotected cells. Combine this technique with careful use of borders and background colours, and you can create a user-friend user interface as well as an efficient system.

Protecting cells is quite simple, but there are two steps involved. Each cell has a property to say whether or not it is protected, and the default setting is Locked (i.e. protected). The first step, therefore, is to set the Locked property to false for all the cells that you need the user to be able to change. To do this, you must highlight all of the cells - you can highlight non-adjacent cells by holding down the Ctrl key as you click. Then, select Cells from the Format menu. On the Protection tab, there are two checkboxes, called Locked and Hidden - make sure that Locked is not ticked.

The final step is to switch on the protection - from the Tools menu, select Protection then Protect Sheet.... You will be prompted for a password - be careful not to enter one unless it is absolutely necessary; I have known a number of students who have forgotten their passwords and have had to start their systems again.

Note that when a sheet is protected, certain features no longer work - AutoSum, for example - even when you're not working with protected cells. Also, if you create a macro that writes to protected cells, you will need to unprotect the sheet at the start of your macro, and then re-protect it at the end.

Logical Operators

Excel recognises the values true and false, and also contains logical operations such as the AND(), OR() and NOT() functions. These work in the usual way, and can be used in calculations as shown in the checkbox example below.

Form Features
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Using the Forms Toolbar (shown right - click the right mouse button on the toolbar and select Forms), you can add common Windows form features, such as combo-boxes and buttons, to your spreadsheet. The two most useful (and easiest to create) are checkboxes and radio buttons (called option buttons in Excel).

Radio Buttons
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Radio buttons (also known as option buttons) are the little buttons normally used for answering multiple-choice questions. Their key feature is that you can only select one at a time (like the stations on a radio - hence the name). You can draw on as many radio buttons as you like, and then link them a cell in your spreadsheet. This cell then displays the number of the button selected - i.e. the first radio button you add inserts a 1, the second a 2, the third a 3, and so on. You can also use them the other way round, i.e. entering a number in the cell sets the corresponding radio button, e.g. entering a 1 "clicks" the first radio button you created.

To link a radio button to a cell, first of all you need to click the appropriate button on the Forms Toolbar - third button down, on the right - and draw on the radio button where you want it to go. To change the text, or move the button later on, use the right mouse button. To link the button to a cell, click the right mouse button on the radio button, and select Format Control.... Go to the Control tab, and you will see the Cell link: field. In here, enter the reference of the cell you want to use, or use the red arrow to select a cell.

All the radio buttons that you create on a sheet are linked to the same cell - you only need to set this property for one of the options. If you want to create several sets of radio buttons, e.g. for several multiple-choice questions, then you need to use a Group Box (second button down on the left of the Forms Toolbar). Draw on the group box, and make sure that all the radio buttons you want to group together are entirely inside the box - this includes the box around the text. All of the radio buttons inside the group box will be linked to the same cell, but those in different group boxes may be linked to different cells.

Checkboxes
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Checkboxes work in a very similar way, except that each one is linked to its own cell in the spreadsheet, and it inserts TRUE into the cell when ticked, and FALSE when not ticked. Again, it's useful to remember that this works the other way round, too - if you enter a 0 in the linked cell, the checkbox is cleared, and if you enter a non-zero value, it becomes ticked.

Remember also that you can use TRUE and FALSE in calculations, so checkboxes are useful for selection options and adding in the costs by multiplying the cost of the option by the value in the linked cell. If the option isn't selected, the cell will contain FALSE, and FALSE behaves in the same way as zero, thereby cancelling the cost.

This is what happens in the checkbox example, shown on the previous page. You can tick the various options, and the total is calculated. The example actually does more than that, because it also contains a stock table, and won't let you select an item that is out of stock. It does this by running a macro when an option is ticked - the macro simply pastes column C onto column B, resetting the button if the item is out of stock.

You can attach a macro to any of the form features by clicking on it with the right mouse button, and then selecting Assign Macro....

Numerical Functions

As you'd imagine, Excel contains a large number of arithmetic, trigonometric and statistical functions. Probably the most interesting from a project point of view are the random number generation and rounding functions.

You can generate a random number using the =rand() function. This generates a (pseudo) random number between 0 and 1 - to get a number between other limits, you need to do a bit of arithmetic. For example, to get a number between 0 and 10, just use =rand()*10, and to get a number between 5 and 15, use =(rand()*10)+5.

This won't give you a whole number, however (unless you're lucky!). You can round to an integer (i.e. whole number) using =int(), but it's important to remember that this always rounds down, so =int(rand()*10) will give you a whole number form 0 to 9. To simulate the roll of a die (a number from 1 to 6), therefore, you would need to use =int(rand()*6)+1.  You might also want to look at how the =mod() function is used in the dice example below.

There are two other rounding functions, called =ceiling() and =floor(). These round up and down, respectively, but also take a second argument, X, and then round the number to the nearest X. So =ceiling(A1, 10), for example, would round the value in cell A1 up to the nearest 10.

Finally, if you’re working with sets of data, the =min(), =max() and =rank() functions may be of interest.  The =min() and =max() functions find the smallest and largest values, respectively, from the given range – e.g. =max(a1:a10) finds the largest value between a1 and a10.

The =rank() function is used to give one value within a set of values a relative position within the set - =rank(x, y, z) will give you the relative position of value x within set y.  If the value of z is zero (or you only enter the first two arguments), the highest value is given the rank 1 (i.e. first).  If z is non-zero, then the lowest value is ranked first.  For example, =rank(a1,a1:a10) will give you the position of the value in cell a1 within the set of data in the range a1:a10, with the highest value ranked 1, and =rank(b3,b1:b10,1) will rank b3 in the set b1:b10, with the lowest value ranked first.

if()

You can make decisions in your spreadsheet using the =if() function. It takes three arguments in order:

· some sort of test - a comparison or function

· what you want to display if the test passes (i.e. returns true)

· what you want to display otherwise

If you want to display a number or the result of a formula, you can just enter that value or formula as your argument. If you want to display text, you need to enclose it in speech marks. For example, if you wanted to simulate a coin toss, you could use the function =if(rand()>0.5,"True","False").

You can nest functions in Excel, so if you wanted to show whether the value in A1 was positive, negative or zero, you could use =if(A1>0,"Positive",if(A1<0,"Negative","Zero")).

vlookup()
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This is a very useful function that enables you to reproduce some of the features of a relational database in Excel. The =vlookup() function (there is also a similar =hlookup() function, in case your table of data is the other way round, i.e. in rows rather than columns) allows you to take a number or some text, and look that value up in a table in your spreadsheet, and then return some corresponding information.

For example, in the spreadsheet shown on the, the function looks up the postcode selected by the user in cell D2, and returns the corresponding town/city. The actual function for this is =VLOOKUP(D4,postcodes,2,FALSE).

You will notice that =vlookup() takes 4 arguments:

· what you want to look up - in this case we want to look up the postcode that has been entered in cell D4

· where you want to look it up from - this must be a range, in this case it's A2:B9, which I've named postcodes (see below).

· the number of the column that contains the information you want to fetch - in this case we want the name of the town/city, which is in the second column of postcodes.

· whether you (don't) want to find exact matches in the table, only - in this example it doesn't make sense, because we're looking up text values, but if the postcode was a number, then setting this argument to TRUE would allow you to match values that aren't in the table (e.g. you could create a table of exam grade boundaries, and then look up any percentage to find the grade).
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There are a couple of things to be aware of.  Firstly, if you want to use TRUE as the last argument, you need to make sure that the numbers in the table you're looking up from are in ascending order, i.e. the smallest number is at the top.

Secondly, if you're going to replicate your formula, you need to make the second argument (the lookup table range) absolute (e.g. by pressing F4), or, better still, give the name as range as I have done. To name a range, you must first highlight it (as shown on the right), and then enter a name in the combo-box above cell A1. Thereafter, you can use this name in formulae, and if you select the name in the combo above A1, the range will become highlighted so you can see where it is. If you need to change the size of the range, select Name from the Insert menu, and then choose Define....

If you use vlookup() to find a value, but there is no match in the table, the function returns #N/A. This can be hidden using conditional formatting (see below) and the =isna() function. The =isna() function returns either TRUE or FALSE, depending on whether a given cell contains #N/A, e.g. =isna(A1) would display TRUE is there was an #N/A in cell A1.

Text Functions

There are also some useful text-manipulation functions in Excel.  You can change the case of text (to either upper, lower, or “proper” case, where the first letter of each work is capitalised), trim characters from the left or the right, remove leading and trailing spaces, and find the length of some text.  These functions are described below – the examples assume that the cell A1 contains the text chipping campden school, A2 contains 2 and A3 contains F1:

	Function
	Description
	Example

	=left(cell, chars)
	Finds the first chars characters from the text in cell
	=left(A1,8) would give you chipping

	=right(cell, chars)
	Finds the last chars characters from the text in cell
	=right(A1,6) would give you school

	=concatenate(cell, cell)
	Joins together the contents of the two cells
	=concatenate(A2,A3) will give you 12F1

	=find(text, cell)
	Finds the location (i.e. the position of the first letter) of text in cell
	=find(“ “,A1) will give you 9

	=proper(cell)
	Capitalises the first letter of each word in cell
	=proper(A1) will give you Chipping Campden School

	=upper(cell)
	Changes the text in cell so that it is all in upper case
	=upper(A1) will give you CHIPPING CAMPDEN SCHOOL

	=lower(cell)
	Changes the text in cell so that it is all in lower case
	=lower(A2) will give you f1

	=len(cell)
	Finds the number of characters in the text in cell
	=len(A1) will give you 23

	=trim(cell)
	Removes all leading and trailing spaces from the text in cell
	=trim(“ A “) will give you just A with no spaces around it


Paste Special

You may have noticed that if you copy and paste values in Excel, you actually copy the formulae rather than the values in the cells. If you use the right mouse button or the Edit menu to select Paste Special... you can choose what you want to copy - formula, value, validation, formatting, etc.

Even more useful is the fact that if you choose to copy just the value in the cell, you can add to, subtract from, divide or multiply by the value that's already in the target cell. This can be useful for subtracting items from stock, for example, or adding medals to a medal table in the example spreadsheet discussed on the macro page.

Conditional Formatting
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Excel allows you to change a number of aspects of the formatting of a cell - font, size, text decoration, colour, etc. You can also use something called conditional formatting (on the Format menu) to change the colour, etc., of a cell according to its value, or even the value of another cell. This is the technique used in the medals system to display the word "Gold" in gold, the word "Silver" in silver, etc.

The dice system (shown on the right) uses random number generation to simulate the roll of a die, and then conditional formatting to show you what the die would look like. It does this by setting the background colour of seven cells, depending on the value in B6 (i.e. the number 5 shown here).

If you want to test the value of another cell, you need to use the Formula is option (rather than Cell value is), as shown below:
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The top-left and bottom-right "spots" are filled in for any value greater than 1. Top-right and bottom left spots are filled in for any value greater than 3. The middle-left and middle-right spots only appear when a 6 is thrown. The only slightly tricky one is the middle spot, which only appears when an odd number is thrown. You can use the =MOD() function to check for this - the =MOD() function performs a division and gives you the remainder. In this case I've used =MOD(B6,2) - if you divide a number by two and there is a remainder, then the number is odd!

Excel Macros

A macro is a small program, or set of commands, that runs inside another application. They allow you to record and automate procedures that take many steps, and repeat them with a keystroke or the click of a button. Excel lets you record macros, but it also lets you create new macros, or edit recorded ones, using a macro language called VBA (VisualBASIC for Applications) which is a subset of the VisualBASIC programming language.

Recording a Macro
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Creating a macro in Excel is quite simple - you can just do manually what you want your macro to do, and record the steps. To start recording, select Macro from the Tools menu, and the choose Record new macro... - the dialogue on the right will appear. Enter a name for your macro (don't be lazy - it will make things much easier later on if you give your macro a proper name) and click OK. A stop button will probably appear, and Excel starts recording your steps.

The next step is to do for yourself what you want your macro to do. When you've done that, click the stop button. If the stop button hasn't appeared, you can stop the recording using the Tools menu (select Macro, and then Stop Recording).

When you record a macro, there are a few things you should bear in mind:

· When you start recording, make sure that you are in the same place (i.e. on the same sheet) as the user will be when the macro is executed, i.e. on the sheet where the button is going to be. If you're going to run the macro from two different sheets, start recording on the sheet that's "furthest" from the sheet where the first step takes place - e.g. if you're going to run the macro from sheet 1 and sheet 2, and the first step in the macro does something to sheet 2, then start recording on sheet 1; this will ensure that the first thing the macro does is go to sheet 2.

· Don't just think about what the macro is going to do - tidy up after yourself! Think about what the user is most likely to be doing next, and help him/her out by changing to the correct sheet and clicking in the correct cell. If your macro does some copying and pasting, you might also want to press Esc before you stop recording, to remove the border from the copied range.

· If you're going to protect your sheet, remember that the first thing your macro will need to do is unprotect the sheet, and the last thing will be to protect the sheet again.

When you record a macro, Excel converts your actions into commands from the VBA programming language. You can have a look at these commands and edit them to do exactly what you want (see the illustration at the top of the next page). For example, if you record a macro to Save As, then your macro will look something like this (the underscore characters indicate that the command continues on the next line).
To see what your macro looks like, select Macro from the Tools menu, and then choose Macros.... Highlight the macro you want to have a look at, and then click the Edit button.
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Adding a Button

You may have noticed from the Record Macro dialogue that you can assign a keystroke to your macro. It's more user friendly, though, to add a button to your worksheet so that you can click to execute the macro. You can add buttons from the Forms toolbar. To view the toolbar, click the right mouse button on the Excel menu bar (i.e. at the top), and select Forms. The Button button is the second one down on the right.

Click the Button button and draw the button onto the worksheet. You can move a button at a later time, or change the text, by clicking on it with the right mouse button. After you've drawn on your button, the Assign Macro dialogue will appear - select your macro and click OK.

Editing Macros

There are some actions you can't record - e.g. closing down Excel, choosing things such as filenames, or reacting to user input. For these, you will need to create or edit a macro yourself using the VBA programming language - I will describe how to do these three things now. In order to minimise the number of commands you need to know (remember that programmed solutions aren't in the nature of the A level ICT course!), you can often record most of what you want your macro to do, and then amend the code slightly afterwards. 

When you're editing a macro, the macro editor does try to help you out a bit. Macros use the same system of objects, methods and properties as does VisualBASIC. When you type a valid object name followed by a full-stop, a list of valid properties and methods for that object will appear. This also helps you out by telling you that you've got the object name right! Also, when you're entering a command that takes many arguments (e.g. msgbox(), discussed below), a tool-tip appears to remind you of the options - the ones in square brackets are optional. 

Referring to Cell Contents

We'll start with the save_as macro you recorded above. That macro will use the same filename every time you run it. Suppose, for example, that you want to allow the user to enter a filename into a cell, B2. The VBA property that contains the contents of cell B2 is range("B2").Value (there are other ways of finding the contents of a cell, but this works as well as any). All you need to do to amend your save_as macro to replace the "C:\My Documents\Book1.xls" with range("B2").Value. Next time you run your macro, the contents of the cell B2 will be used as the filename.

While a command like range(“a1”).value is the easiest way to refer to the contents of a cell, you can also use the command activesheet.cells(row,column).value, where row and column are numbers – i.e. range(“c5”).value is equivalent to activesheet.cells(5,3).value.  While this might seem more difficult, it means that you can select cells using either random numbers or the results of a calculation.

Dates in Excel

In the example, I've put a formula (=INT(NOW()*1000000) in B2 so that each time the spreadsheet is saved, it has a unique name. The =now() function returns the current date and time, but it's useful to remember that dates are stored internally as the number of days since 1/1/1900 - this means, for example, that you can go back or forward a week by simply subtracting 7 from, or adding 7 to a date.  You could also work out what day of the week a given date is on by subtracting a date with a known weekday, and using the =mod() function (e.g. 20/10/2002 is a Sunday, so if 20/10/2002 was in A1, =mod(now()-A1,7) would give you the day of the week as a number – you could then use =vlookup() to give it a name).

Creating a New Macro
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You can start a menu from scratch by selecting Macro from the Tools menu, and then choosing Macros.... If you enter a valid name in the Macro Name: field, the Create button will become enabled, and you can click it to start a new macro. If you want to create a macro that closes Excel, for example, simply enter application.quit as shown in the example below. You can then add a button in the usual way, and use the macro.

Note that if you've changed your spreadsheet, then running your macro will do the same as trying to close Excel using the menu, Alt F4 or the Close button - i.e. you will be asked if you want to save your file. If you want to have more control over the user interface and stop this happening, you can use the msgbox() and if commands.

Using msgbox() and if
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The msgbox() command can be used to display messages for the user. If you want to use it in this way, you just need to give it a string as an argument, e.g. msgbox("Hello!").  Note that you do not have to use a fixed value – you can use a value from a cell, or the result of a calculation.

You can also change the type (i.e. the types of buttons that appear below the message) of the message, and use the command to record the user's response. For example, you can have Yes, No, Cancel, etc. buttons on your message, and check which one the user clicked. When you use msgbox() in this way, it always returns a value, so you need to use it with a variable or another function that takes a value, such as if. It's probably easiest to use an example - you could use if and msgbox() to ask the user whether he/she wants to save before closing Excel:

Note that there is also an inputbox() command that works in a similar way and allows the user to enter a number or some text.

What you can see above is the finished macro. When the close_down macro is executed, the use is asked "Do you want to save?" ("Save" is the window title for the message). If Yes is clicked, the spreadsheet is saved using the save_as macro. Notice that you can run another macro by simply including its name in your macro.

If you try to close Excel without saving, it will prompt you to save - the else case tidies this up so that the user isn't asked again. ThisWorkbook has a property called Saved, which indicates whether the spreadsheet has been saved since the last change was made. If the user wants to abandon the changes, we can "trick" Excel into thinking that there are no changes to be saved (in which case it won't ask) by setting the value of Saved to True.

The final step is to close Excel, using application.quit, which we want to do regardless of which button the user clicks.

Updating the Screen

If there is a lot of steps in your macro, or it changes between sheets, then there can be a lot of flickering going on while your macro is running.  There is a property in Excel’s VBA called application.screenupdating, which takes the values true or false.  To stop the screen flickering while your macro is running, set application.screenupdating = false at the top of your macro, and then set application.screenupdating = true again at the bottom – if you don’t set the value back to true, then you won’t be able to see what your macro has done!

Events

While the most common way to start a macro will be to click a button that you have added to the worksheet, you can also trigger a macro using other events.  

If you press Alt + F11 to view the Visual Basic editor, you can select these other events.  The tree at the top-left shows all the objects in Excel – if you double-click one of the branches, the associated code window will appear in the right-hand pane.

At the top of the code window, there are two combo boxes – the one on the left normally defaults to (General) – this is used for things like variable and function declarations, which are beyond the scope of A level ICT.

If you select the other option (e.g. Workbook in the example shown here), the right-hand combo box will be filled with all the events that can occur within that object – i.e. whether it can be clicked, double-clicked, opened, closed, etc.

When you choose one of the event types, a new subroutine (i.e. macro) will be created, and this subroutine will be associated with the event you selected – e.g. if you selected Activate for a Workbook object, then the macro will be run whenever someone selects that sheet.

You can then enter any commands that you want to be associated with this action.  Remember that you can run any other macro, e.g. one that you have already recorded, just by entering its name – see the if…then…else example above.

Web Links

Some of the examples from this booklet can be downloaded from the Excel and Macro pages in the MS Office section of www.advanced-ict.info.

